Unofficial Austrumi Linux for English users forum golf & dvd

A Latvian and english Linux tiny operating system. used by golf & dvd lovers

You are not logged in.

Adverts

Adverts

#1 2010-10-17 15:41:57

Steve92
Guest

How to set keyboard type at boot time ?

Hello again !

Is there a "cheat code" to set keyboard type at boot time ?

I've tested with

keymap=fr-latin1 fr_FR

that works with other distribs launched by vmlinuz but doesn't with Austrumi.

Why ?

Steve92

Last edited by Steve92 (2010-10-17 15:47:34)

 

2010-10-17 15:41:57

AdBot
Advertisements

#2 2010-10-17 16:26:06

atang1
Administrator
Registered: 2006-03-30
Posts: 2705

Re: How to set keyboard type at boot time ?

Austrumi has cheat codes for 5 languages. French is not one of them. Once you selected one language, the keyboardmap is set. Default language is Russian, because of install script from Blin. Then you can change keyboard map for any apps(wordprocessor). Alt-shift gets it back to the keyboard language you chose on boot up.

If you should decide to offer French as another language, study how the greek language was remastered into Austrumi choice of languages. Many GUI files had to be changed from Russian to Greek along with locale, l18n, keyboardmap, etc. Then remaster that Austrumi version with all the new  French files. Are you able to take on such a task?

Offline

 

#3 2010-10-24 22:04:55

Steve92
Guest

Re: How to set keyboard type at boot time ?

Hi!

I've no problem with Austrumi menus language.
After reboot of Austrumi LIVE USB, menus are in french but keyboard is not (US).
The "save & quit" option on exit works for language but not for keyboard setting ?!?

To avoid clicking about 7 times to change it with Austrumi "Parameters" GUI after each reboot, I click on a tiny script I made, /root/kb_fr.sh, with :

setxkbmap -layout fr

...and it works fine !

But I've to manually launch this script after each reboot ! :(

I tried to edit /etc/rc.d/rc.local and added these lines :

setxkbmap -layout fr

or

loadkeys fr

...but it doesn't work ! :(

Of course, I used the option "Save and Quit" and after reboot, I see my modification in rc.local so it is persistent but doesn't work...
I always have an US keyboard ! :(

Please heeeeeeelp !

Where do I have to put these f*cking lines :

setxkbmap -layout fr
or
loadkeys fr
or
...something else...

???
Ok, I go to sleep before it makes me crazy ! ;)

Regards,

Steve92

Last edited by Steve92 (2010-10-24 22:07:46)

 

#4 2010-10-25 07:49:12

atang1
Administrator
Registered: 2006-03-30
Posts: 2705

Re: How to set keyboard type at boot time ?

This is because you try to make english language version french without considering french as a language by its own files in french. All austrumi files started with russian version. Then switched to english, therefore you can not have another language in the english version. Language has to start with a file system that russian version can switch to?

I found out, when I switch from russian to english and lost all data in the russian version, not carried over to the english version.

You have to change the keyboard map in text editor or email client(add fuction of switching keyboards) to be able to use a foreign font in text and can switch back to english(US keyboard) within the softaware application. On the other hand, you can write in english then translate into other languages and fonts much easier than changing keyboards, although translation is often done poorly. Then, you just have a local function(in a file) and not a system function(in a file system).

Offline

 

Adverts

Board footer

Powered by FluxBB
Hosted by PunBB-Hosting